TextMate 1.x under Mavericks

If you are using TextMate 2.0 then the following info does not apply to you.

Many of the bundle items in TextMate are written with ruby and were coded for version 1.8. With Mavericks Apple has updated the default version of ruby to 2.0. While we recommend everyone switch to 2.0 we realize that some people are hesitant to switch during a major project or similar.

If you wish to use TextMate 1.x on Mavericks you will need to tell TextMate to use ruby 1.8 for bundle items by putting the path to it first via the PATH variable.

Open Preferences from the TextMate menu and go to the Advanced section and select the Shell Variables tab. Click the + button to add a new variable named PATH with a value of:

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin

Make sure when copying this that there is no whitespace before or after the string and that it is on a single line.

If you wish to use another version of ruby for user scripts then set TM_RUBY to the path to your custom installed ruby. This is what will be used for Ruby → Run (⌘R), Ruby → Validate Syntax (⌃⇧V), and similar actions where user code is executed or scanned.

We previously sent out an email instructing 1.x users to update the shebang, those instructions are still valid, but we have since realized that the above is a simpler fix.